summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGitlab CI Runner2020-06-22 06:45:20 +0000
committerGitlab CI Runner2020-06-22 06:45:20 +0000
commitdaf2ca2d8a1fa834319edc4bfc2ab0cf91f5f7da (patch)
treef799b70d1e4348f59a3ff11a57045706a895f002 /PKGBUILD
parent964b8dbba18153c97c37216153968a05121b8ec2 (diff)
downloadaur-daf2ca2d8a1fa834319edc4bfc2ab0cf91f5f7da.tar.gz
Updated package to exec-helper commit 54b2e4cc1fe81874cbb9a0e96fed3a57543f8001
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30f2398352e2..1ef0de8da7f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bart Verhagen <barrie.verhagen@gmail.com>
pkgname=('exec-helper' 'exec-helper-docs')
pkgbase='exec-helper'
-pkgver=0.5.0_0_g4571947
+pkgver=0.5.1_0_g8869989
pkgrel=1
epoch=
pkgdesc="How To Get Coffee In Peace: a shell meta-wrapper"
@@ -10,7 +10,7 @@ url="https://github.com/bverhagen/exec-helper"
license=('GPL3')
groups=()
depends=(yaml-cpp boost-libs)
-makedepends=(cmake boost make doxygen graphviz git pkg-config microsoft-gsl lsb-release)
+makedepends=(cmake boost make python-sphinx python-sphinx_rtd_theme git pkg-config microsoft-gsl lsb-release)
checkdepends=(catch2 rapidcheck)
optdepends=()
provides=()
@@ -20,7 +20,7 @@ backup=()
options=()
install=
changelog=exec-helper.changelog
-source=('exec-helper::git+https://github.com/bverhagen/exec-helper.git#commit=457194703c49bc2982cc68c671ed4831285fe03c')
+source=('exec-helper::git+https://github.com/bverhagen/exec-helper.git#commit=8869989a59b352f340406ae8859958bf343be776')
noextract=()
validpgpkeys=()
@@ -34,7 +34,7 @@ pkgver() {
build() {
_system_description=$(lsb_release --description --short | sed 's/"//g')
- _source_version=0.5.0_0_g4571947
+ _source_version=0.5.1_0_g8869989
_release_version="($_system_description) $_source_version"
_copyright="Copyright (c) $(date +'%Y') Bart Verhagen"
@@ -42,7 +42,7 @@ build() {
_exec_helper_build_targets=('exec-helper' 'docs-man')
_exec_helper_docs_build_targets=('docs-html')
- cmake -G "Unix Makefiles" -H"$_git_dir" -B"$_build_dir" -DCMAKE_INSTALL_PREFIX="$pkgdir/usr/" -DCMAKE_BUILD_TYPE=Release -DUSE_SYSTEM_YAML_CPP=ON -DUSE_SYSTEM_GSL=ON -DBUILD_HTML_DOCUMENTATION=ON -DBUILD_MAN_DOCUMENTATION=ON -DENABLE_TESTING=OFF -DENABLE_WERROR=OFF -DVERSION="$_release_version" -DCOPYRIGHT="$_copyright" -DACTUAL_PLUGINS_INSTALL_PREFIX=/usr/share/exec-helper/plugins
+ cmake -G "Unix Makefiles" -H"$_git_dir" -B"$_build_dir" -DCMAKE_INSTALL_PREFIX="$pkgdir/usr/" -DCMAKE_BUILD_TYPE=Release -DUSE_SYSTEM_YAML_CPP=ON -DUSE_SYSTEM_GSL=ON -DBUILD_USAGE_DOCUMENTATION=ON -DBUILD_API_DOCUMENTATION=OFF -DENABLE_TESTING=OFF -DENABLE_WERROR=OFF -DVERSION="$_release_version" -DCOPYRIGHT="$_copyright" -DACTUAL_PLUGINS_INSTALL_PREFIX=/usr/share/exec-helper/plugins
make --directory "$_build_dir" --jobs ${_nb_of_cores} ${_exec_helper_build_targets[@]} ${_exec_helper_docs_build_targets[@]}
}