summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKian Kasad2021-02-14 13:46:15 -0800
committerKian Kasad2021-02-14 13:46:15 -0800
commitd39d38f97456053521c8ea73d7be92261b90d4a9 (patch)
treec69abe85b3f7dc768db411093f8157a1d763c7e9 /PKGBUILD
downloadaur-d39d38f97456053521c8ea73d7be92261b90d4a9.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a172e5792aff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kian Kasad <kian at kasad.com>
+pkgname=execline-man-pages-git
+pkgver=v2.7.0.1.2.r0.970eab3
+pkgrel=1
+pkgdesc='Manual pages for the execline suite of software'
+arch=('any')
+url='https://github.com/flexibeast/execline-man-pages'
+license=('ISC')
+groups=()
+depends=()
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p "$pkgdir/usr/share/man/man1" "$pkgdir/usr/share/man/man7"
+ make MANPATH="$pkgdir/usr/share/man" install
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}