summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorimperzer02022-05-17 07:16:57 +0300
committerimperzer02022-05-17 07:16:57 +0300
commit77cdd66075d5935fdaea7291a813a23f0327a249 (patch)
treedfb3bdef055c4086a4a6614d76e2af9ef40eb19a /PKGBUILD
downloadaur-77cdd66075d5935fdaea7291a813a23f0327a249.tar.gz
created package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46d73ad3cfa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Mainained by imper <imperator999mcpe@gmail.com>
+pkgname="execute-process-linux"
+pkgver=2.5
+pkgrel=0
+pkgdesc="advanced process execution static library"
+author="imperzer0"
+branch="master"
+url="https://github.com/$author/$pkgname"
+arch=('x86_64')
+license=('GPL3')
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+
+_srcprefix="https://raw.githubusercontent.com/$author/$pkgname/$branch"
+_libfiles=("execute-process-linux" "execute-process-linux-defs")
+
+for _libfile in ${_libfiles[@]}
+{
+ source=(${source[@]} "$_srcprefix/$_libfile")
+}
+
+md5sums=('503cbd766917491444a63472d6861eed'
+ '1963c2f59044568b3ecfd588b56852da')
+
+prepare()
+{
+ curl -L "$_srcprefix/PKGBUILD" > PKGBUILD-git
+}
+
+build()
+{
+ . PKGBUILD-git && build
+}
+
+package()
+{
+ . PKGBUILD-git && package
+} \ No newline at end of file