summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSkunnyk2020-05-17 23:36:12 +0200
committerSkunnyk2020-05-17 23:36:12 +0200
commit4a7a65ce300cbcf38fdfcb3d807d8201b0e67046 (patch)
tree646bf45e369103280825a7f85933187c53ecc66d /PKGBUILD
parent75d25aa40dfcad98568c8e1409c861589627829d (diff)
downloadaur-4a7a65ce300cbcf38fdfcb3d807d8201b0e67046.tar.gz
Rework PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 13 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c42f3292f87f..bc0b0e034e59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,42 +6,35 @@
# Contributor: Jan Jezek <honzin.jezek@gmail.com>
# Contributor: Berseker <berseker86 at gmail dot com>
-pkgname=exo-git
-pkgver=0.12.0.r2131.03df63a
-pkgrel=2
+_pkgname=exo
+pkgname=${_pkgname}-git
+pkgver=0.12.11+68+ga978d108
+pkgrel=1
pkgdesc="Extensions to Xfce originally developed by os-cillation."
arch=('i686' 'x86_64')
license=('GPL2' 'LGPL2.1')
-url="https://git.xfce.org/xfce/exo/tree/README"
+url="https://gitlab.xfce.org/xfce/exo/"
groups=('xfce4-git')
provides=("exo=${pkgver}")
-depends=('libxfce4util>=4.12' 'gtk3>=3.22' 'glib2>=2.42' 'gtk2>=2.24' 'hicolor-icon-theme' 'libxfce4ui>=4.12' 'libsm')
-makedepends=('xfce4-dev-tools' 'git' 'pkgconfig' 'libnotify' 'perl-uri' 'pygtk>=2.13')
+depends=('hicolor-icon-theme' 'libxfce4ui')
+makedepends=('xfce4-dev-tools' 'git' 'pkgconfig' 'libnotify' 'perl-uri')
optdepends=('libnotify: enables notification support'
'perl: enables mail-compose helper script')
conflicts=('exo')
-source=('exo-git::git://git.xfce.org/xfce/exo')
+source=("${_pkgname}::git+https://gitlab.xfce.org/xfce/${_pkgname}.git")
options=('!libtool')
md5sums=('SKIP')
epoch=1
pkgver(){
- cd exo-git
- _majorversion=$(grep -F "m4_define([libexo_version_major]" configure.ac.in | awk 'BEGIN {FS = "["} {print $3}' | sed -r 's/(\[|\])//g' | sed -r 's/(\(|\))//g')
- _minorversion=$(grep -F "m4_define([libexo_version_minor]" configure.ac.in | awk 'BEGIN {FS = "["} {print $3}' | sed -r 's/(\[|\])//g' | sed -r 's/(\(|\))//g')
- _microversion=$(grep -F "m4_define([libexo_version_micro]" configure.ac.in | awk 'BEGIN {FS = "["} {print $3}' | sed -r 's/(\[|\])//g' | sed -r 's/(\(|\))//g')
+ cd "${_pkgname}"
+ git describe --long --tags | sed -r "s:^${_pkgname}.::;s/^v//;s/^exo-//;s/-/+/g"
+# git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
- printf "%s." "$_majorversion"
- printf "%s." "$_minorversion"
- printf "%s." "$_microversion"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $srcdir/exo-git
-
- # Python 2 fix
- export PYTHON=python2
+ cd "${_pkgname}"
./autogen.sh \
--prefix=/usr \
@@ -50,13 +43,11 @@ build() {
--localstatedir=/var \
--disable-static \
--enable-gtk-doc \
- --enable-gtk2 \
- --enable-gtk3 \
--disable-debug
make
}
package() {
- cd $srcdir/exo-git
+ cd "${_pkgname}"
make DESTDIR=$pkgdir install
}