summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFeresey2019-12-01 23:18:54 +0300
committerFeresey2019-12-01 23:18:54 +0300
commit722a9b7f062ce71aeed5830ca3ec7729a4cf5a04 (patch)
treea3657a0bfc319699743c2402b928e235b9bb3f45 /PKGBUILD
parent25682ff7f30c1cbd516e05d6cda21334efa551e0 (diff)
downloadaur-722a9b7f062ce71aeed5830ca3ec7729a4cf5a04.tar.gz
orig repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6352b5df3cf..f845204f9207 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,27 @@
# Maintainer: Feresey <p.milko1999@yandex.ru>
pkgname=exo-player
+_gitname=exo
arch=(x86_64)
pkgdesc="eXo music player based on mocp, with QT5 graphics"
-pkgver=8.0
-pkgrel=6
+pkgver=9.0
+pkgrel=1
source=(git://github.com/Feresey/exo)
-url=https://blaze.alwaysdata.net/exo
+url=https://github.com/loimu/exo
sha1sums=('SKIP')
license=(GPL)
-install=${pkgname}.install
makedepends=(gcc cmake)
-depends=(hicolor-icon-theme liblastfm-qt5 desktop-file-utils)
-_gitname=exo
+depends=(liblastfm-qt5 python desktop-file-utils hicolor-icon-theme)
+optdepends=("python-notify2: for moc-osd")
-build() {
+prepare() {
cd "${srcdir}/${_gitname}"
[[ ! -d build ]] && mkdir build
- cd build
- cmake .. -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" -DCMAKE_BUILD_TYPE=Release
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"/build
make
}