summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFeresey2019-08-07 03:17:12 +0300
committerFeresey2019-08-07 03:17:12 +0300
commitc39d37466c6162112c5172e37f6fda7aa73cdf0f (patch)
tree8a829e01bd9f3dc719e041a5e5ba5102e0be35cc /PKGBUILD
downloadaur-c39d37466c6162112c5172e37f6fda7aa73cdf0f.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c97c6803a9dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Feresey <p.milko1999@yandex.ru>
+pkgname=exo-player
+arch=(x86_64 i686)
+pkgdesc="eXo music player based on moc"
+pkgver=8.0
+pkgrel=1
+source=(git://github.com/Feresey/exo)
+url=https://github.com/Feresey/exo
+sha1sums=('SKIP')
+license=(GPL)
+
+makedepends=(gcc cmake)
+depends=(liblastfm-qt5
+ qt5-base
+ moc
+ python3)
+
+build() {
+ cd $srcdir
+ cd exo
+ [[ ! -d build ]] && mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=$pkgdir/usr
+ make
+}
+
+package() {
+ cd $srcdir/exo/build
+ make install
+}
+