summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorthanx2016-03-28 21:41:57 +0200
committerthanx2016-03-28 21:41:57 +0200
commit9651381bf57cb2d0e93cc6273d42d74997c01cfd (patch)
tree295f5a89b0cf5300cfdb893f55a8b4c677b8041d /PKGBUILD
downloadaur-9651381bf57cb2d0e93cc6273d42d74997c01cfd.tar.gz
Inital package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b61a183e4d1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Archtrack maintainer: Evan Teitelman <teitelmanevan@gmail.com>
+# Contributor: Thanx <thanxm@gmail.com>
+pkgname=exploit-db-git
+_gitname="exploit-database"
+pkgver="git"
+pkgrel=1
+pkgdesc="The Exploit Database (EDB) an ultimate archive of exploits and vulnerable software - A collection of hacks"
+url="https://github.com/offensive-security/exploit-database"
+license=("custom")
+arch=('any')
+depends=('bash' 'wget' 'grep' 'sed' 'tar')
+options=('!strip')
+source=("git+https://github.com/offensive-security/${_gitname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ local ver="$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ printf "%s" "${ver//-/.}"
+}
+
+
+package() {
+ # The script
+ #install -Dm755 $srcdir/exploit-db.sh $pkgdir/usr/bin/exploit-db
+
+ # The database
+ chmod -R 644 "$srcdir/${_gitname}"
+ chmod -R a+X "$srcdir/${_gitname}"
+ install -dm 755 "$pkgdir/usr/share"
+ cp -dr --no-preserve=ownership "$srcdir/${_gitname}" "$pkgdir/usr/share/exploit-db"
+ ln -s "/usr/share/exploit-db" "${pkgdir}/usr/share/exploitdb"
+}
+
+
+