summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2020-10-17 01:20:09 +0200
committerMartin T. H. Sandsmark2020-10-17 01:20:09 +0200
commit830ebdf650e753e1a2972d365711deab637fcebf (patch)
tree96db944e59ca707a787b083295716cc66450df2c /PKGBUILD
downloadaur-830ebdf650e753e1a2972d365711deab637fcebf.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72a9b24370c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Martin Sandsmark <martin.sandsmark@kde.org>
+
+pkgname=extra-imageformats-qt-git
+pkgver=r11.fe4356c
+pkgrel=1
+pkgdesc='bpg, pgf and fuif support for Qt'
+arch=('i686' 'x86_64')
+url='https://github.com/sandsmark/extra-imageformats-qt'
+license=('LGPL')
+depends=('qt5-base')
+optdepends=(
+ 'libbpg: BPG supprt'
+ 'libpgf: PGF support'
+)
+makedepends=('git' 'cmake')
+conflicts=(extra-imageformats-qt)
+provides=(extra-imageformats-qt)
+source=('git://github.com/sandsmark/extra-imageformats-qt.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd extra-imageformats-qt
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd extra-imageformats-qt
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd extra-imageformats-qt
+ make DESTDIR="$pkgdir" install
+}