summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2021-09-01 16:00:00 +0300
committerCaleb Maclennan2021-09-01 16:00:00 +0300
commitceb694925a170573dcef9ec343f368277ecb0a40 (patch)
treeece8011e4bf2c0969107f0d4eac7ead22a4aad3c /PKGBUILD
parentc1d7375d21098ac9d75a096b40fccb4a06e536a2 (diff)
downloadaur-ceb694925a170573dcef9ec343f368277ecb0a40.tar.gz
upgpkg: ezra-bible-app-git 1.2.0.r4.gba4b665-1
upgpkg: ezra-bible-app 1.2.0-1 upstream release Normalize and work and updating (not finished yet)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD95
1 files changed, 48 insertions, 47 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9816cf40d68..ed6d6f7bed8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,69 +1,70 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=ezra-bible-app-git
-pkgver=0.12.1.r25.g7104405
+pkgver=1.2.0.r4.gba4b665
pkgrel=1
pkgdesc='A user-friendly Bible study tool focussing on topical study based on keywords/tags'
-arch=('x86_64')
+arch=(x86_64)
url="https://github.com/${pkgname%-git}/${pkgname%-git}"
-license=('GPL3')
-depends=('electron'
- 'icu'
- 'nodejs')
-makedepends=('git'
- 'jq'
- 'moreutils'
- 'node-gyp'
- 'node-prune'
- 'nodejs-addon-api' # run time dep but gets baked into electron asar
- 'nodejs-pug-cli'
- 'nodejs-sword-interface>=0.222.0' # run time dep but gets baked into electron asar
- 'npm')
-provides=("${pkgname%-git}" "ezra-project-git")
-conflicts=(${provides[@]} "ezra-project-git")
-replaces=("ezra-project-git")
+license=(GPL3)
+depends=(electron
+ icu
+ nodejs)
+makedepends=(git
+ jq
+ moreutils
+ node-gyp
+ node-prune
+ nodejs-addon-api # run time dep but gets baked into electron asar
+ nodejs-pug-cli
+ nodejs-sword-interface # run time dep but gets baked into electron asar
+ npm)
+provides=("${pkgname%-git}"
+ ezra-project-git)
+conflicts=("${provides[@]}")
+replaces=(ezra-project-git)
source=("git+$url.git"
"${pkgname%-git}.sh")
sha256sums=('SKIP'
'e135a382166ce27cf1348750767e157b2d292d4a189940f0fa874af29bc6540b')
pkgver() {
- cd "${pkgname%-git}"
- git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${pkgname%-git}"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${pkgname%-git}"
- jq 'del(.dependencies["node-addon-api", "node-sword-interface"], .devDependencies["electron", "electron-osx-sign", "node-abi", "node-gyp", "pug-cli", "sequelize-cli"])' package.json |
- sponge package.json
- rm -rf node_modules/{node-addon-api,node-sword-interface}
- npm install --cache "$srcdir/npm-cache" --no-audit --no-fund --ignore-scripts
+ cd "${pkgname%-git}"
+ jq 'del(.dependencies["node-addon-api", "node-sword-interface"], .devDependencies["electron", "electron-osx-sign", "node-abi", "node-gyp", "pug-cli", "sequelize-cli"])' package.json |
+ sponge package.json
+ rm -rf node_modules/{node-addon-api,node-sword-interface}
+ npm install --cache "$srcdir/npm-cache" --no-audit --no-fund --ignore-scripts
}
build() {
- cd "${pkgname%-git}"
- local _electron="$(electron --version | sed 's/^v//')"
- npx electron-rebuild -f --version="$_electron"
- node-prune node_modules
- _ep () {
- npx electron-packager ./ "${pkgname%-git}" \
- --electron-version="$_electron" \
- --overwrite \
- --platform=linux \
- --arch=x64 $@
- }
- _ep
- ./build_scripts/purge_build_artifacts.sh
- npm link node-addon-api node-sword-interface
- _ep --asar
+ cd "${pkgname%-git}"
+ local _electron="$(electron --version | sed 's/^v//')"
+ npx electron-rebuild -f --version="$_electron"
+ node-prune node_modules
+ _ep () {
+ npx electron-packager ./ "${pkgname%-git}" \
+ --electron-version="$_electron" \
+ --overwrite \
+ --platform=linux \
+ --arch=x64 $@
+ }
+ _ep
+ ./build_scripts/purge_build_artifacts.sh
+ npm link node-addon-api node-sword-interface
+ _ep --asar
}
package() {
- cd "${pkgname%-git}"
- install -Dm755 "../${pkgname%-git}.sh" "$pkgdir/usr/bin/${pkgname%-git}"
- install -Dm644 -t "$pkgdir/usr/share/applications/" "${pkgname%-git}.desktop"
- install -Dm644 -t "$pkgdir/usr/lib/${pkgname%-git}/resources/" "${pkgname%-git}-linux-x64/resources/app.asar"
- install -Dm644 -t "$pkgdir/usr/share/licences/$pkgname/" LICENSE
- install -Dm644 -t "$pkgdir/usr/share/doc/${pkgname%-git}/" {CHANGELOG,README,TECH,LOC_METRICS}.md
- install -Dm644 icons/ezra.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/${pkgname%-git}.svg"
+ cd "${pkgname%-git}"
+ install -Dm755 "../${pkgname%-git}.sh" "$pkgdir/usr/bin/${pkgname%-git}"
+ install -Dm644 -t "$pkgdir/usr/share/applications/" "${pkgname%-git}.desktop"
+ install -Dm644 -t "$pkgdir/usr/lib/${pkgname%-git}/resources/" "${pkgname%-git}-linux-x64/resources/app.asar"
+ install -Dm644 -t "$pkgdir/usr/share/licences/$pkgname/" LICENSE
+ install -Dm644 -t "$pkgdir/usr/share/doc/${pkgname%-git}/" {CHANGELOG,README,TECH,LOC_METRICS}.md
+ install -Dm644 icons/ezra.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/${pkgname%-git}.svg"
}