summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMathieu Westphal2021-11-23 22:28:18 +0100
committerMathieu Westphal2021-11-23 22:28:18 +0100
commit83f15aa1bb027c51438f740e9ab7f1a36c63a9f8 (patch)
treeb595086a4b93beb308a49f7e67373a9e19cfd3b6 /PKGBUILD
parentbbb78614b5e5b190b1aa2c57cac9be7e3889b85a (diff)
downloadaur-83f15aa1bb027c51438f740e9ab7f1a36c63a9f8.tar.gz
Adding opencascade and ospray dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 16dfb286c26d..4dcfc38287dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
# Maintainer: Michael Migliore <mcmigliore+aur@gmail.com>
+# Maintainer: Mathieu Wespthal <mathieu.westphal+aur@gmail.com>
+export GIT_LFS_SKIP_SMUDGE=1
pkgname=f3d
pkgver=1.1.1
pkgrel=1
@@ -7,8 +9,8 @@ pkgdesc='A fast and minimalist 3D viewer'
arch=('x86_64')
url="https://gitlab.kitware.com/${pkgname}/${pkgname}"
license=('BSD')
-depends=('vtk')
-makedepends=('cmake' 'openmp')
+depends=('vtk' 'ospray')
+makedepends=('git' 'git-lfs' 'cmake')
source=("https://github.com/$pkgname-app/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('68bdbe3a90f2cd553d5e090a95d3c847e2a2f06abbe225ffecd47d3d29978b0a')
@@ -27,4 +29,4 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver/build"
make DESTDIR="$pkgdir" install
-} \ No newline at end of file
+}