summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Harvey2015-07-17 21:43:35 +0000
committerJames Harvey2015-07-17 21:43:35 +0000
commit427a7298651ec57a4253e842582757dca0c11211 (patch)
tree406457a199574f4a78066fcf6068b79864ed5b7f /PKGBUILD
downloadaur-427a7298651ec57a4253e842582757dca0c11211.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d61a7196b3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: James Harvey <jamespharvey20@gmail.com>
+# * No namcap warnings or errors
+
+pkgname=fabtests
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='OpenFabrics Alliance high performance fabric library tests using libfabric'
+arch=('x86_64' 'i686')
+url=('https://www.openfabrics.org/index.php/overview.html')
+license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
+depends=('libfabric' 'bash')
+source=("https://www.openfabrics.org/downloads/ofi/${pkgname}-${pkgver}.tar.gz")
+md5sums=('fc1952e9f53def1748d9910aacaf3a31')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}