summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarek Kubica2010-09-19 22:14:02 +0200
committerMarek Kubica2010-09-19 22:14:02 +0200
commit388cd44114b06cbdb35975aa5b08bf849d286451 (patch)
treee17e6605c9814ed4fdd471922d6e68ce3027f571 /PKGBUILD
parent767112cf8bce39932b5fd4e75cc0c0dba4113f9b (diff)
downloadaur-388cd44114b06cbdb35975aa5b08bf849d286451.tar.gz
Adjusted PKGBUILD for 0.94 release. Deleted wrapper script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d5f3cc59e1b..6dc60e0ada8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leonidas <marek@xivilization.net>
pkgname=factor
-pkgver=0.93
-pkgrel=4
+pkgver=0.94
+pkgrel=1
pkgdesc="Factor is a general purpose, dynamically typed, stack-based programming language."
arch=(i686 x86_64)
url="http://factorcode.org"
@@ -11,12 +11,10 @@ conflicts=(factor-git)
depends=(pango cairo glib2 freetype2 mesa libgl)
options=(!strip)
source=(http://downloads.factorcode.org/releases/$pkgver/$pkgname-src-$pkgver.zip
- factor-vm
factor.desktop
factor.png
fuel-factor-vm.patch)
-md5sums=('d5507d193e3b8c22e4d0be1a4a213934'
- '172985592832c63157888bce652c273c'
+md5sums=('6c89c27ed3127f9b0f308f3b3dba34a2'
'59242ddb19a9be927915e489e2bfca27'
'74512251d922434c3a973f06800d6181'
'642c6aeafe3d8e6c41df8a12d4b42f44')
@@ -48,11 +46,13 @@ build() {
chmod -R 0755 $pkgdir/usr/lib/factor
find $pkgdir/usr/lib/factor -type f -exec chmod -x {} \;
- # copy over the actual binary
- cp -a factor $pkgdir/usr/bin/factor-bin
- # copy over the wrapper that calls factor with the proper image
- cp $srcdir/factor-vm $pkgdir/usr/bin/factor-vm
- chmod +x $pkgdir/usr/bin/factor-vm
+ # copy over the actual binary and create a symlink called factor-vm
+ # (otherwise it conflicts with factor from the GNU coreutils)
+ cp -a factor $pkgdir/usr/lib/factor/factor
+ cd $pkgdir/usr/bin
+ ln -s ../lib/factor/factor factor-vm
+ cd -
+
# copy over the license (as defined in Arch Packaging Standards)
chmod -x license.txt
cp license.txt $pkgdir/usr/share/licenses/$pkgname/COPYING