summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororhun2020-11-12 19:11:24 +0300
committerorhun2020-11-12 19:11:24 +0300
commit05234f07f48112cc111da244bb1ebee824fb8003 (patch)
tree32ee11c8d15be29bf7755f952ecdd94bfc3b0b42 /PKGBUILD
downloadaur-05234f07f48112cc111da244bb1ebee824fb8003.tar.gz
Initial upload: faint 0.97-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bed82dea7d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=faint
+pkgdesc="Extensible TUI fuzzy file explorer"
+pkgver=0.97
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/salman-abedin/faint"
+license=('unknown')
+depends=('fzf')
+makedepends=('make')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('a16b24d09af92f13045514fb6a5344ca232f68d72fe1d2a86a40112af71494bc')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make BIN_DIR="$pkgdir/usr/bin" install
+ install -Dm 644 "README.md" -t "$pkgdir/usr/share/doc/$pkgname"
+}