summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBastian Löher2016-05-20 12:23:05 +0200
committerBastian Löher2016-05-20 12:23:05 +0200
commitc221296f9f6a5e31d4e6732c25f8121b88342663 (patch)
treed2bdfb0f957366e93b069110de5352ac86e1aae1 /PKGBUILD
parentd671ee63ede290696258aa017d8987dacc4c1f81 (diff)
downloadaur-c221296f9f6a5e31d4e6732c25f8121b88342663.tar.gz
Add patch to fix return types in BoostSerializer.h.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae939a62a86f..38daf40020b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,10 +28,12 @@ install=fairroot.install
changelog=
source=("https://github.com/FairRootGroup/FairRoot/archive/v-${pkgver}.tar.gz"
'fairroot.install'
+ 'fix_return.patch'
)
noextract=()
md5sums=('775fb31d5c3b99f363a5c9eb9c301698'
- 'd2d2d7b11b308120382fba7e32c5268a')
+ 'd2d2d7b11b308120382fba7e32c5268a'
+ '6aa0d1c3b2fc936ce54b9f5acf6c338e')
# Do not compress the package for installation
# PKGEXT='.pkg.tar'
@@ -42,6 +44,9 @@ prepare() {
# Path to fairsoft installation
export SIMPATH=/opt/fairsoft/${fairsoftver}
+ cd ${srcdir}
+ patch -Np0 -i ${startdir}/fix_return.patch
+
cd ${srcdir}/FairRoot-v-${pkgver}
# Execute cmake