summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOtakar Jašek2020-08-30 17:28:19 +0200
committerOtakar Jašek2020-08-30 17:28:19 +0200
commit445518be55d081502a2893017ed1f53921875369 (patch)
tree4c8ba526e0d5536164f9bfe5c9a43e421c0af9a7 /PKGBUILD
parentc493025f955a201196278c136eced9ac09cd2ea2 (diff)
downloadaur-445518be55d081502a2893017ed1f53921875369.tar.gz
default cuda archs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b168369810b8..8af7bd87fe5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: otaj <jasek.ota@gmail.com>
-# If you want to set only one GPU target compute capability, set _GPU_TARGET, otherwise leave it commented out and it will build default targets (35, 52, 60 and 61). You can also set multiple targets separated by semicolon
+# If you want to set only one GPU target compute capability, set _GPU_TARGET, otherwise leave it commented out and it will build default targets (52, 60, 61, 70 and 75). You can also set multiple targets separated by semicolon
-_GPU_TARGET="75"
+#_GPU_TARGET="75"
_pkgname=faiss
pkgbase=faiss-cuda-git
pkgname=('faiss-cuda-git' 'python-faiss-cuda-git')
@@ -34,6 +34,8 @@ prepare() {
if ! [ -z "$_GPU_TARGET" ]
then
_CMAKE_FLAGS=$_CMAKE_FLAGS"-DCMAKE_CUDA_ARCHITECTURES=\""$_GPU_TARGET"\""
+ else
+ _CMAKE_FLAGS=$_CMAKE_FLAGS"-DCMAKE_CUDA_ARCHITECTURES=\"\"52 60 61 70 75\"\""
fi
cmake $_CMAKE_FLAGS ..
}