summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOtakar Jašek2019-04-09 10:27:19 +0200
committerOtakar Jašek2019-04-09 10:27:19 +0200
commitb8639776f8ab5372f86599e8664aec3b43a7197f (patch)
tree6ae4262da451215898678779199ebdf3eac44f87 /PKGBUILD
parentd290da45837282ad4a9493d34006a5b709dc8a77 (diff)
downloadaur-b8639776f8ab5372f86599e8664aec3b43a7197f.tar.gz
No patch needed anymore
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dcf75ac18226..3e776889f86c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: otaj <jasek.ota@gmail.com>
# If you want to set only one GPU target compute capability, set _GPU_TARGET, otherwise leave it commented out and it will build default targets (35, 52, 60 and 61)
-_GPU_TARGET=61
+#_GPU_TARGET=61
_pkgname=faiss
pkgbase=faiss-cuda-git
pkgname=('faiss-cuda-git' 'python-faiss-cuda-git' 'python2-faiss-cuda-git')
@@ -10,9 +10,8 @@ url="https://github.com/facebookresearch/faiss"
license=('BSD')
pkgver=v1.5.1.r0.g7f5b22b
pkgrel=1
-source=(${_pkgname}::git+https://github.com/facebookresearch/faiss.git 'cuda10.1.patch')
-sha256sums=('SKIP'
- '88be494d517b4879e2dfbf91f74d6f9bc851d038639c5f51f4820278f0309e28')
+source=(${_pkgname}::git+https://github.com/facebookresearch/faiss.git)
+sha256sums=('SKIP')
depends=('blas' 'lapack' 'cuda')
makedepends=('python' 'python2' 'python-numpy' 'python2-numpy' 'swig' 'python-setuptools' 'python2-setuptools')
@@ -27,7 +26,6 @@ prepare() {
cd "${srcdir}/${_pkgname}"
cp -ar python python2
sed -i 's/makefile.inc/makefile2.inc/g' python2/Makefile
- patch -Np1 < ../cuda10.1.patch
}
@@ -36,7 +34,7 @@ build() {
_CONF_FLAGS="--prefix=/usr --with-cuda=/opt/cuda"
if ! [ -z "$_GPU_TARGET" ]
then
- _CONF_FLAGS="$_CONF_FLAGS --with-cuda-arch=-gencode=arch=compute_$_GPU_TARGET,code=compute_$_GPU_TARGET"
+ _CONF_FLAGS="$_CONF_FLAGS --with-cuda-arch=-gencode=arch=compute_$_GPU_TARGET,code=sm_$_GPU_TARGET"
fi
./configure $_CONF_FLAGS --with-python=python2
mv makefile.inc makefile2.inc