summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2015-06-17 23:59:49 +0200
committerGordian Edenhofer2015-06-17 23:59:49 +0200
commitecbf8c2b4e7d57eb96ac567b3d7f742588d1cb12 (patch)
tree0e9903b19f42ef84ecf4f1e912e340f13a7a664e /PKGBUILD
parentbdbd473ea1ce92147e3ee6827278d011a89681b2 (diff)
downloadaur-ecbf8c2b4e7d57eb96ac567b3d7f742588d1cb12.tar.gz
Updated pkgver + fetching by tags + new dep + man
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1dcb3f2be465..95fa8148fb6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
pkgname=fakepkg
-pkgver=1.21.3
+pkgver=1.21.4
pkgrel=1
pkgdesc="A tool to reassemble installed packages from its deliverd files. It comes in handy if there is no internet connection available and you have no access to an up-to-date package cache."
arch=('any')
license=('GPL2')
url="https://github.com/Edenhofer/bin"
-depends=('bash>=4.2' 'pacman' 'tar' 'gzip' 'parallel')
-source=("https://raw.githubusercontent.com/Edenhofer/bin/master/fakepkg")
-md5sums=('SKIP')
+depends=('bash>=4.2' 'pacman' 'tar' 'xz' 'gzip' 'parallel')
+source=("${pkgname}-${pkgver}.zip"::"https://github.com/Edenhofer/fakepkg/archive/v${pkgver}.zip")
+md5sums=('205336d9d2add15a31c96e9852bd75d2')
package() {
- cd "${srcdir}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- install -D -m755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m644 "man/${pkgname}.1" "${pkgdir}/usr/share/man/man1/${pkgname}.1"
}