summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPellegrino Prevete2022-07-15 18:55:17 +0000
committerPellegrino Prevete2022-07-15 18:55:17 +0000
commitd7bf23d7aa463b4cd578d7e1f12593d76bfe94d7 (patch)
tree00a17d1386ec1e6ac45f757b2614cfc1ee5cf22c /PKGBUILD
downloadaur-d7bf23d7aa463b4cd578d7e1f12593d76bfe94d7.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..653b9d818193
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+# Contributor: Gordian Edenhofer <gordian.edenhofer@gmail.com>
+
+# shellcheck disable=SC2034
+_pkgname=fakepkg
+pkgname="${_pkgname}-git"
+pkgver=1.42.0
+pkgrel=1
+pkgdesc="Tool to reassemble installed packages from its deliverd files. It comes in handy if there is no internet connection available and you have no access to an up-to-date package cache"
+arch=('any')
+license=('GPL2')
+url="https://github.com/Edenhofer/fakepkg"
+_url="https://gitlab.archlinux.org/tallero/${_pkgname}"
+depends=('bash>=4.2' 'pacman' 'tar' 'gzip' 'sed' 'awk')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}-${pkgver}.tar.gz::${_url}/archive/v${pkgver}.tar.gz")
+sha512sums=('a0cbced9fa2c15114881ed71915671141b91efdf265a851a35013dfa1e34be328c80f47cabcb9e04262baa1a32e6f4e47a893cc7af0eb1b2dc4190712667f4b6')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ install -D -m755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -D -m644 "man/${_pkgname}.1" "${pkgdir}/usr/share/man/man1/${_pkgname}.1"
+}