aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp Schmitt2016-05-06 08:31:24 +0200
committerPhilipp Schmitt2016-05-06 08:31:24 +0200
commit502c000f33d1b2b029dfabc434aaff14bc029ce8 (patch)
treea528d4e410fdf1ca86eeee38ea71857bcd007811 /PKGBUILD
parent28c7e2485490d64794f804f672987d643f3afde7 (diff)
downloadaur-502c000f33d1b2b029dfabc434aaff14bc029ce8.tar.gz
Fix PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f089570fb49..8d6904da0475 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philipp Schmitt <philipp@schmitt.co>
# Upstream: https://github.com/phillipberndt/fakexrandr
pkgname=fakexrandr-git
-pkgver=0.0.0
+pkgver=r68.bb5ee75
pkgrel=1
pkgdesc="Fake XRandR configurations for multi-head setups with crappy video drivers, like fakexinerama but with xrandr"
arch=(any)
@@ -17,8 +17,7 @@ _lib_dir=/usr/lib/$_pkgname
pkgver() {
cd "$srcdir/$pkgname"
- # Use the tag of the last commit
- git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
@@ -32,6 +31,7 @@ prepare() {
sed -i "s|\(install\) \(.*\) \(.*\);|\1 \2 \3/\2;|" Makefile
# Fix missing DEST_DIR in Makefile
sed -i "s|\(TARGET_DIR=\).*|\1${pkgdir}${_lib_dir}; \\\|" Makefile
+ sed -i "s|\(PREFIX=\).*|\1${pkgdir}\/usr|" Makefile
# Don't even try to run ldconfig now
sed -i "s/\(ldconfig\)/#\1/" Makefile
# Create ld.so.conf.d config file
@@ -46,8 +46,7 @@ build() {
package() {
cd "$srcdir/$pkgname"
- echo cd "$srcdir/$pkgname"
- mkdir -p "$pkgdir/$_lib_dir"
+ mkdir -p "$pkgdir/$_lib_dir" "${pkgdir}/usr/bin"
make install
install -D -m 644 "${_pkgname}.conf" "$pkgdir/etc/ld.so.conf.d/${_pkgname}.conf"
}