summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcodemunkii2015-08-05 20:54:14 -0400
committercodemunkii2015-08-05 20:54:14 -0400
commit28c64af1d42eba53e31d63149816cc98639a8bdd (patch)
tree7cea93f41d34b256438c67a30439b9f8b69385e7 /PKGBUILD
downloadaur-fang.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d23f9f09ddc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ari Mizrahi <codemunchies at debugsecurity dot com>
+# Contributor: ArchAssault Project <https://www.archassault.org>
+
+pkgname=fang
+pkgver=git
+pkgrel=3
+pkgdesc="A multi service threaded MD5 cracker"
+arch=('any')
+url=('https://github.com/evilsocket/fang')
+license=('GPL2')
+makedepends=('git')
+depends=('python2')
+source=('git+https://github.com/evilsocket/fang')
+md5sums=('SKIP')
+backup=('etc/fang.conf')
+
+prepare() {
+ cd "$srcdir/fang"
+
+ # Follow standards, put config files in /etc.
+ sed -i 's|fang\.conf|/etc/fang.conf|' fang.py
+
+ # Fix shebang header.
+ sed -i 's|python$|python2|' fang.py
+}
+
+package() {
+ cd "$srcdir/fang"
+
+ install -dm755 "$pkgdir/etc"
+ install -dm755 "$pkgdir/usr/bin"
+
+ install -m755 fang.py "$pkgdir/usr/bin/fang"
+ install -m644 fang.conf "$pkgdir/etc/fang.conf"
+}