summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2021-08-12 16:33:35 -0400
committerGI_Jack2021-08-12 16:33:35 -0400
commit58b109c306debafc8c3859dd16372bd6e6ab4fae (patch)
tree8c2c823dbb0f09012dc9a7d68cfba04c6a0b2123 /PKGBUILD
downloadaur-58b109c306debafc8c3859dd16372bd6e6ab4fae.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75f624fb4052
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: GI_Jack <GI_Jack@hackermail.com>
+
+pkgbase="fantasma"
+_pkgbase="Fantasma"
+pkgname=("otf-${pkgbase}" "ttf-${pkgbase}")
+pkgver=1.0
+pkgrel=1
+pkgdesc="Fantasma: An 「ael-lab」 Release AEL-01 // Font design by Froyo Tam AEL-01"
+arch=('any')
+url="https://github.com/froyotam/ferrite-core/"
+license=('GPLv3')
+source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/froyotam/Fantasma/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('c6965ab7d12117026e48738f50a61f7e9c54dacc918bb515afa55326d5ef8522')
+
+package_ttf-fantasma() {
+ pkgdesc="Fantasma: An 「ael-lab」 Release AEL-01 // Font design by Froyo Tam AEL-01(TTF True Type Font)"
+ cd "${_pkgbase}-${pkgver}"
+ install -Dm644 fonts/Fantasma-Regular.ttf "${pkgdir}/usr/share/fonts/TTF/Fantasma-Regular.ttf"
+}
+
+package_otf-fantasma() {
+ pkgdesc="Fantasma: An ael-lab Release AEL-01 // Font design by Froyo Tam AEL-01(OTF Open Type Font)"
+ cd "${_pkgbase}-${pkgver}"
+ install -Dm644 fonts/Fantasma-Regular.otf "${pkgdir}/usr/share/fonts/TTF/Fantasma-Regular.otf"
+}