summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaichi Shinozaki2015-06-09 18:14:27 +0900
committerDaichi Shinozaki2015-06-09 18:14:27 +0900
commit72dca4d789186b6789af53c26a7a23d69d98bc36 (patch)
treed85f62309ed16cd98bc90f3643a2759e87484a21 /PKGBUILD
downloadaur-72dca4d789186b6789af53c26a7a23d69d98bc36.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be50357fd195
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
+# Contributor: ahmad200512@yandex.ru
+pkgname=fantom
+pkgver=1.0.67
+pkgrel=1
+pkgdesc="Programming language supposed to run on top of JVM or CLR or in browser as JavaScript"
+arch=('i686' 'x86_64')
+url="http://fantom.org/"
+license=('custom:Academic Free License 3.0')
+depends=('java-runtime')
+install=$pkgname.install
+source=(https://bitbucket.org/fantom/fan-1.0/downloads/${pkgname}-${pkgver}.zip LICENSE
+ fantom.profile)
+md5sums=('3f505db3e8e629914d6849e8739a6477'
+ '6f6f26e10fee5edcfa0dff72274e6d28'
+ '24709c14c5d3b5e12e5bfd2712d7a2f4')
+options=('!purge')
+replaces=('fan-language')
+package() {
+ mkdir -p ${pkgdir}/opt/${pkgname}
+ rm $srcdir/${pkgname}-${pkgver}/bin/*.exe
+ chmod 755 $srcdir/${pkgname}-${pkgver}/bin/*
+ cp -R ${srcdir}/${pkgname}-${pkgver}/* ${pkgdir}/opt/${pkgname}
+ install -Dm644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/fantom/LICENSE
+ install -Dm644 ${srcdir}/fantom.profile ${pkgdir}/etc/profile.d/fantom.sh
+}
+
+# vim:set ts=2 sw=2 et: