summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDamien Robert2020-02-20 16:43:27 +0100
committerDamien Robert2020-02-20 16:43:27 +0100
commitacadd70b8be64270fda25dd3f50dcd917ad886a1 (patch)
tree9b80a91d41c52d3594043f8847d0bb3252f55421 /PKGBUILD
parent3e870bb4a8a9e20e4d8a71e5a0c7df2577a030a3 (diff)
downloadaur-acadd70b8be64270fda25dd3f50dcd917ad886a1.tar.gz
Fix license installation path
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d2886226d0a..75c79686e8a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=fast-p
pkgver=0.2.5
-pkgrel=2
+pkgrel=3
pkgdesc='Quickly find and open a pdf among a collection of thousands of unsorted pdfs through fzf (fuzzy finder)'
arch=('x86_64')
repo="github.com/bellecp/$pkgname"
@@ -14,16 +14,16 @@ sha256sums=('ccd0a4630433a0ed000278f93c15300fd8bf47e612967568d824ad4ab23fb3ac')
gopkg="gopath/src/$repo"
prepare() {
- mkdir -p ${gopkg%/*}
- ln -rTsf $pkgname-$pkgver $gopkg
- export GOPATH="$srcdir"/gopath
- cd $gopkg
+ mkdir -p "${gopkg%/*}"
+ ln -rTsf "$pkgname-$pkgver" "$gopkg"
+ export GOPATH="$srcdir/gopath"
+ cd "$gopkg"
go get -v -d
}
build() {
export GOPATH="$srcdir"/gopath
- cd $gopkg
+ cd "$gopkg"
go install \
-trimpath \
-ldflags "-extldflags $LDFLAGS" \
@@ -38,7 +38,7 @@ build() {
# }
package() {
- install -Dm755 gopath/bin/$pkgname "$pkgdir"/usr/bin/$pkgname
- cd $pkgname-$pkgver
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/LICENSE
+ install -Dm755 "gopath/bin/$pkgname" -t "$pkgdir/usr/bin"
+ cd "$pkgname-$pkgver"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}