summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVahlblue2020-09-06 21:57:59 +0200
committerVahlblue2020-09-06 21:59:58 +0200
commita5fe3643478cf61281bbff907e2f094c771492dd (patch)
treedb425dabd01a15361ee6e3aac9a50522252f1d10 /PKGBUILD
downloadaur-fast-wfc-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f9530194242
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Vahlblue <c@vahl.blue>
+pkgname=('fast-wfc-git')
+pkgver=r90.854230a
+pkgrel=1
+pkgdesc='An implementation of Wave Function Collapse in C++'
+arch=('any')
+url='https://github.com/math-fehr/fast-wfc'
+license=('MIT')
+makedepends=('gcc' 'make' 'cmake')
+provides=('fast-wfc')
+source=("git+https://github.com/math-fehr/fast-wfc")
+sha512sums=('SKIP')
+
+prepare() {
+ cd fast-wfc
+ cmake .
+}
+
+pkgver() {
+ cd fast-wfc
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd fast-wfc
+ make
+}
+
+package() {
+ cd fast-wfc
+
+ make DESTDIR=${pkgdir} install
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}