summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLackOfDream2016-07-11 10:24:30 +0900
committerLackOfDream2016-07-11 10:24:30 +0900
commitf2d3a182014d223ec97a653647e5cb563cfcde2a (patch)
treed559e289aab00073a3a3f2da8723d66aff3ca9b7 /PKGBUILD
downloadaur-f2d3a182014d223ec97a653647e5cb563cfcde2a.tar.gz
Initial commit for PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b158ed410cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Ning Humbert <galaxy0419@gmail.com>
+pkgname=fastdriver-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=1345b24
+pkgrel=1
+pkgdesc="Fast-ODP (Old-Driver-Protocol) command line tool, C++ implementation"
+arch=('i686' 'x86_64')
+url="https://github.com/lackofdream/fastdriver"
+license=('Apache')
+depends=(crypto++)
+makedepends=('git' 'cmake') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("fastdriver")
+options=("!buildflags")
+source=('git+https://github.com/lackofdream/fastdriver.git')
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+_gitname=fastdriver
+
+pkgver() {
+ cd $_gitname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd $_gitname/src
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make VERBOSE=1
+}
+
+package() {
+ cd $_gitname/src/build
+ make DESTDIR="$pkgdir/" install
+}