summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-02-21 08:31:34 -0700
committerMark Wagie2023-02-21 08:31:34 -0700
commit40abe06400a1823a173d30fedf17e4660416cbf5 (patch)
treef64d485b6c4d48667c1ed8f23748a3e6c3a00403 /PKGBUILD
parent9ab58c86ac55e0d38f3e4f5e8d35173c0701b6d4 (diff)
downloadaur-40abe06400a1823a173d30fedf17e4660416cbf5.tar.gz
1.10.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3452075ecac..538316471bd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=fastfetch
-pkgver=1.9.1
-pkgrel=4
+pkgver=1.10.1
+pkgrel=1
pkgdesc="Like Neofetch, but much faster because written in C"
arch=('x86_64' 'aarch64' 'riscv64')
url="https://github.com/LinusDierheimer/fastfetch"
license=('MIT')
depends=('gcc-libs')
-makedepends=('chafa' 'cmake' 'dbus' 'dconf' 'imagemagick' 'libnm' 'libxcb'
+makedepends=('chafa' 'cmake' 'dbus' 'dconf' 'imagemagick' 'libnm' 'libpulse' 'libxcb'
'libxrandr' 'mesa' 'ocl-icd' 'opencl-headers' 'pciutils'
'vulkan-headers' 'vulkan-icd-loader' 'wayland' 'xfconf' 'zlib')
optdepends=(
'chafa: Image output as ascii art'
- 'dbus: Needed for detecting current media player and song'
+ 'dbus: Bluetooth, Player & Media detection'
'dconf: Needed for values that are only stored in DConf + Fallback for GSettings'
'glib2: Output for values that are only stored in GSettings'
'imagemagick: Image output using sixel or kitty graphics protocol'
'libnm: Used for Wifi detection'
+ 'libpulse: Used for Sound detection'
'mesa: Needed by the OpenGL module for gl context creation.'
'libxrandr: Multi monitor support'
'ocl-icd: OpenCL module'
@@ -27,7 +28,7 @@ optdepends=(
)
backup=("etc/$pkgname/config.conf")
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('0b6d31bc213282b26a7c2fc9706d41e1669a7ea8875154ba6aed1ba428c92b3d')
+sha256sums=('3741521d265ac948cbf0fe3a098b3296d1b18d16f3a159fd6669794ef720525b')
build() {
cmake -B build -S "$pkgname-$pkgver" \