summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-01-22 09:15:09 -0700
committerMark Wagie2023-01-22 09:15:09 -0700
commit94b0f6209ab0c13f7e03fd39c55a9a73c2d5c238 (patch)
tree457336a0d2b26edec529d8b476ccb61d62bb2a8e /PKGBUILD
parentc513ea2ed648b15f369529e6116051641a81355d (diff)
downloadaur-94b0f6209ab0c13f7e03fd39c55a9a73c2d5c238.tar.gz
1.9.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 805988150614..d5eff6f75be6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,33 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=fastfetch
-pkgver=1.8.2
+pkgver=1.9.0
pkgrel=1
pkgdesc="Like Neofetch, but much faster because written in C"
arch=('x86_64')
url="https://github.com/LinusDierheimer/fastfetch"
license=('MIT')
-depends=('glibc')
-makedepends=('chafa' 'cmake' 'dbus' 'dconf' 'imagemagick' 'libxcb' 'libxrandr' 'mesa'
- 'ocl-icd' 'opencl-headers' 'pciutils' 'vulkan-headers' 'vulkan-icd-loader'
- 'wayland' 'xfconf' 'zlib')
+depends=('gcc-libs')
+makedepends=('chafa' 'cmake' 'dbus' 'dconf' 'imagemagick' 'libnm' 'libxcb'
+ 'libxrandr' 'mesa' 'ocl-icd' 'opencl-headers' 'pciutils'
+ 'vulkan-headers' 'vulkan-icd-loader' 'wayland' 'xfconf' 'zlib')
optdepends=(
'chafa: Image output as ascii art'
'dbus: Needed for detecting current media player and song'
'dconf: Needed for values that are only stored in DConf + Fallback for GSettings'
'glib2: Output for values that are only stored in GSettings'
'imagemagick: Image output using sixel or kitty graphics protocol'
- 'mesa: OpenGL module / Improved AMD GPU output'
+ 'libnm: Used for Wifi detection'
+ 'mesa: Needed by the OpenGL module for gl context creation.'
'libxrandr: Multi monitor support'
'ocl-icd: OpenCL module'
'pciutils: GPU output'
- 'vulkan-icd-loader: Fallback for GPU output'
+ 'vulkan-icd-loader: Vulkan module & fallback for GPU output'
'xfconf: Needed for XFWM theme and XFCE Terminal font'
'zlib: Faster image output when using kitty graphics protocol'
)
backup=("etc/$pkgname/config.conf")
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('552f4239a83d31e2fb14bdf7fc5d74cc6cc819f8b6ddd2346ba0dcfac13ac62a')
+sha256sums=('b43b8f3053a417b8138918d2efb46172ddc8d42183ad8707fb1dace63917e448')
build() {
cmake -B build -S "$pkgname-$pkgver" \