summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLinus Dierheimer2023-01-27 11:13:05 +0100
committerLinus Dierheimer2023-01-27 11:13:05 +0100
commit067bcf970fb8e5198c7bd3cab52b194b10f24941 (patch)
tree09f3f404ae6d6b665dcaf2f351ddce7a65c959c4 /PKGBUILD
parent75e4da72d08c2f072d3c8276ee268a0ff7c1e60d (diff)
downloadaur-fastfetch-git.tar.gz
Update dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 29 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f15bf6be0fcd..06fb6e8dadaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Linus Dierheimer <Linus@Dierheimer.de>
pkgname=fastfetch-git
-pkgver=1.9.1.r21.g7adb160
+pkgver=1.9.1.r25.gb0c1925
pkgrel=1
pkgdesc="Like neofetch, but much faster because written in c"
arch=("x86_64" "i686" "pentium4" "armv5" "armv6h" "armv7h" "aarch64" "riscv64")
@@ -14,50 +14,46 @@ depends=(
makedepends=(
"git"
"cmake"
+ "chafa"
+ "dbus"
+ "dconf"
+ "glib2"
+ "imagemagick"
+ "libnm"
+ "libpulse"
+ "libx11"
+ "libxcb"
+ "libxrandr"
+ "mesa"
+ "ocl-icd"
+ "opencl-headers"
"pciutils"
"vulkan-headers"
"vulkan-icd-loader"
"wayland"
- "libxcb"
- "libxrandr" # Depends on libX11, which headers are also needed
- "dconf" # Depends on glib2, which headers are also needed
- "imagemagick"
- "chafa"
- "zlib"
- "dbus"
"xfconf"
- "mesa"
- "opencl-headers"
- "ocl-icd"
- # "libmagick6"
- # "sqlite3"
- # "rpm-tools"
- # "libcjson"
+ "zlib"
)
optdepends=(
- "pciutils: GPU output"
+ "chafa: Image output as ascii art"
+ "dbus: Bluetooth, Media & Player modules"
+ "dconf: Output for values that are only stored in DConf"
+ "glib2: Output for values that are only stored in GSettings"
+ "imagemagick: Image output using sixel or kitty graphics protocol"
"libdrm: Improved AMD GPU output"
- "vulkan-icd-loader: GPU fallback"
- "wayland: Improved Wayland support (resolution + multi monitor)"
- "libxcb: Improved X11 support (resolution + multi monitor)"
+ "libnm: Better wifi support"
+ "libpulse: Sound module"
"libx11: Improved X11 support (resolution)"
+ "libxcb: Improved X11 support (resolution + multi monitor)"
"libxrandr: Improved X11 support (resolution + multi monitor)"
- "glib2: Output for values that are only stored in GSettings"
- "dconf: Output for values that are only stored in DConf"
- "dbus: Bluetooth, Media & Player modules"
- "imagemagick: Image output using sixel or kitty graphics protocol"
- "chafa: Image output as ascii art"
- "zlib: Faster image output when using kitty graphics protocol"
- "xfconf: XFWM theme + xfce-terminal font"
"mesa: OpenGL module"
- "ocl-icd: OpenCL module"
"nix: self contained nix package count"
- "libnm: Better wifi support"
- "libpulse: Sound module"
- # "libmagick6: ImageMagick 6 support"
- # "sqlite3: rpm package count"
- # "rpm-tools: slower rpm package count fallback"
- # "libcjson: WSL Terminal font"
+ "ocl-icd: OpenCL module"
+ "pciutils: GPU module"
+ "vulkan-icd-loader: Vulkan module & GPU module fallback"
+ "wayland: Improved Wayland support (resolution + multi monitor)"
+ "xfconf: XFWM theme + xfce-terminal font"
+ "zlib: Faster image output when using kitty graphics protocol"
)
_provides_and_conflicts=(