summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLinus Dierheimer2022-01-12 02:05:43 +0100
committerLinus Dierheimer2022-01-12 02:05:43 +0100
commit732242c900fecef5141e0a01d7ad864ef1954301 (patch)
treededae6f3181d0356613baaa87e0dd8ae1a994153 /PKGBUILD
parentbb5f9315b7509663d390e5ed6c6cc45a9ca38966 (diff)
downloadaur-732242c900fecef5141e0a01d7ad864ef1954301.tar.gz
Only build fastfetch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8bb4869b5f96..c7d0bade5de2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Linus Dierheimer <Linus@Dierheimer.de>
pkgname=fastfetch-git
-pkgver=r517.7a3bf2f
+pkgver=r543.322e5c5
pkgrel=1
pkgdesc="Like neofetch, but much faster because written in c"
arch=("any")
@@ -54,14 +54,13 @@ build()
mkdir -p build/
cd build/
cmake ..
- cmake --build .
+ cmake --build . --target fastfetch # don't build flashfetch, as it is meant to be configured at compile time. So it doesn't make sense to pre build it.
}
package() {
cd ${srcdir}/fastfetch
install -D "build/fastfetch" "${pkgdir}/usr/bin/fastfetch"
- install -D "build/flashfetch" "${pkgdir}/usr/bin/flashfetch"
install -D "completions/bash" "${pkgdir}/usr/share/bash-completion/completions/fastfetch"
install -Dd "${pkgdir}/usr/share/fastfetch/presets/"