summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2022-05-22 20:14:07 +0000
committerBioArchLinuxBot2022-05-22 20:14:07 +0000
commit708eb336b1e28a5b7e112915aa2ad355ed776577 (patch)
treecf5a8b9d3b25d4ab72ca77ada13c93a768984f52 /PKGBUILD
parentedb6572a757fb6f656d47ddbe05aababd8fa014e (diff)
downloadaur-708eb336b1e28a5b7e112915aa2ad355ed776577.tar.gz
[lilac] updated to 0.23.2-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a2c9589d01f..9d7c13d6605f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,27 @@
# Contributor: Baytars <feicuihuangfeng@qq.com>
# Maintainer: Baytars <feicuihuangfeng@qq.com>
pkgname=fastp
-pkgver=r337.424900e
-pkgrel=1
+pkgver=0.23.2
+pkgrel=4
pkgdesc="a tool designed to provide fast all-in-one preprocessing for FastQ files, developed in C++ with multithreading supported to afford high performance"
url="https://github.com/OpenGene/fastp"
license=('MIT')
arch=('any')
depends=('zlib')
-makedepends=('git' 'make')
+makedepends=('libdeflate' 'isa-l' 'make')
provides=(${pkgname})
conflicts=(${pkgname})
-source=("${pkgname}::git+${url}.git")
-sha512sums=('SKIP')
+source=("https://github.com/OpenGene/fastp/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('70e4050bd0fcb15ec37b3e57bc0e4d7e67c9d1064f9693da86ca7c0d8dd4117be44c1cf93882d74f30774e81fc9f47c0c39e5db2831368aa43c0aa9ed57f2a82')
-pkgver() {
- cd "$srcdir/${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-$pkgver"
make
}
package() {
- cd "${srcdir}/${pkgname}"
- mkdir -p "${pkgdir}/usr/local/bin/${pkgname}"
- install ${pkgname} ${pkgdir}/usr/local/bin/${pkgname}
+ cd "${srcdir}/${pkgname}-$pkgver"
+ mkdir -p "${pkgdir}/usr/bin/${pkgname}"
+ install ${pkgname} ${pkgdir}/usr/bin/${pkgname}
}