summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Werkmeister2019-11-25 00:42:03 +0100
committerLucas Werkmeister2019-11-25 00:42:03 +0100
commitf0aed27af9fdace1b17ca5594a68ba9d0d0ed830 (patch)
treedf1ab6a423103a3ee2aa9032df6cd702092955d2 /PKGBUILD
parentdbf9234c85cf65572918d3c385a8518caffc9dbc (diff)
downloadaur-fastr-bin.tar.gz
Turn into virtual package for update to 19.3.0
With the 19.3.0 release, GraalVM supports two Java versions: Java 8 and Java 11. This also affects all sibling packages, including FastR, so the former fastr-bin package is split in two: fastr-jdk8-bin and fastr-jdk11-bin. To leave old installs functional when they update, this package is retained, but only as a “virtual” package with no contents except for its dependencies. Since this package only used to provide the Java 8 version, it now declares a dependency on fastr-jdk8-bin (users may additionally or instead install fastr-jdk11-bin, if they want to). Users should install the real package explicitly; I intend to remove this one eventually.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 6 insertions, 52 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed263ec13e08..a8af5acda293 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,12 @@
# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
-pkgname_=fastr
-pkgname=${pkgname_}-bin
-pkgver_=19.2.1
-pkgver=${pkgver_/-/_}
+pkgname=fastr-bin
+pkgver=19.3.0
pkgrel=1
-pkgdesc='Graal based, high-performance implementation of the R language'
+pkgdesc='Virtual package for backwards compatibility; please directly install fastr-jdk8-bin instead'
arch=('x86_64')
url='https://github.com/oracle/fastr'
license=('GPL3')
-depends=('graal')
-makedepends=()
-optdepends=()
-provides=("$pkgname_")
-conflicts=("$pkgname_")
-source=("https://github.com/oracle/$pkgname_/releases/download/vm-${pkgver_}/r-installable-linux-amd64-${pkgver_}.jar")
-sha256sums=('cf5a8e28e2aa12d1801c57b81a24a93abbd2bd98fa6253eb1e9817f3d85e5a3f')
-
-package() {
- local file eq permissions mode name target
-
- mkdir -p "$pkgdir/usr/lib/jvm/java-8-graal/"
- cp -a -t "$pkgdir/usr/lib/jvm/java-8-graal/" jre/ LICENSE_FASTR 3rd_party_licenses_fastr.txt
-
- printf '\n' >> META-INF/permissions
- while read -r file eq permissions; do
- if [[ $eq != '=' ]]; then
- printf >&2 'second word should be "=": %s %s %s\n' "$file" "$eq" "$permissions"
- return 1
- fi
- case $permissions in
- 'rw-------') mode=600;;
- 'rw-r--r--') mode=644;;
- 'rw-rw-r--') mode=664;;
- 'rwxr-xr-x') mode=755;;
- 'rwxrwxr-x') mode=775;;
- 'rwxrwxrwx') continue;; # symbolic link
- *)
- printf >&2 'unknown permissions: %s\n' "$permissions"
- return 1
- ;;
- esac
- chmod "$mode" -- "$pkgdir/usr/lib/jvm/java-8-graal/$file"
- done < META-INF/permissions
-
- printf '\n' >> META-INF/symlinks
- while read -r name eq target; do
- if [[ $eq != '=' ]]; then
- printf >&2 'second word should be "=": %s %s %s\n' "$name" "$eq" "$target"
- return 1
- fi
- mkdir -p -- "$pkgdir/usr/lib/jvm/java-8-graal/$(dirname -- "$name")"
- ln -s -- "$target" "$pkgdir/usr/lib/jvm/java-8-graal/$name"
- done < META-INF/symlinks
-
- install -DTm644 LICENSE_FASTR "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
+depends=('fastr-jdk8-bin')
+source=()
+sha256sums=()