summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndré Kugland2022-01-27 04:49:54 -0300
committerAndré Kugland2022-01-27 04:49:54 -0300
commit3803661837a89f9693aee88afa2ec1eb2468eeea (patch)
tree5b18bb8c8ea5e488a1adb963cc3393aa4d845166 /PKGBUILD
downloadaur-3803661837a89f9693aee88afa2ec1eb2468eeea.tar.gz
v1.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f154cbe60d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname="fastrandom"
+pkgver="1.0.1"
+pkgrel="1"
+pkgdesc="Quickly generate large amounts of cryptographically insecure
+pseudo-random data"
+arch=("x86_64")
+url="https://gitlab.com/kugland/fastrandom"
+license=("MIT")
+source=(
+ "https://gitlab.com/kugland/fastrandom/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz"
+)
+sha256sums=('5453e07d52d32e28dd142363ad70523384ea91bc91ad1893b5a9f8f7e13df382')
+
+package() {
+ cd "${pkgname}-v${pkgver}"
+ LDFLAGS="$LDFLAGS -Wl,--no-as-needed"
+ make DESTDIR="$pkgdir" install
+}