summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhys Perry2019-09-07 17:17:24 +0100
committerRhys Perry2019-09-07 17:17:24 +0100
commit70a8eaf572a6a8421945053c873e30392263b88f (patch)
tree6b0d92daff11ca12e77339e7209df9cadb9d80a9 /PKGBUILD
downloadaur-70a8eaf572a6a8421945053c873e30392263b88f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de6d9c506d7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname="fathom-git"
+pkgrel=1
+pkgver="i.dont.know.what.to.put.here"
+pkgdesc="Fathom - simple website analytics (Community Edition)"
+url="https://github.com/usefathom/fathom"
+license=("MIT")
+arch=("any")
+provides=("fathom")
+conflicts=("fathom")
+
+makedepends=("git" "go-pie" "npm")
+
+source=("git+https://github.com/usefathom/fathom.git")
+md5sums=("SKIP")
+_gitname="fathom"
+
+prepare(){
+ mkdir -p gopath/src/github.com/usefathom
+ ln -rTsf "$_gitname" gopath/src/github.com/usefathom/fathom
+ export GOPATH="$srcdir"/gopath
+}
+
+build(){
+ export GOPATH="$srcdir"/gopath
+ cd "$srcdir"/"$_gitname"
+ make build
+}
+
+package(){
+ cd "$srcdir"/"$_gitname"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ install -Dm755 fathom "$pkgdir"/usr/bin/fathom
+} \ No newline at end of file