summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhys Perry2019-09-10 21:34:01 +0200
committerRhys Perry2019-09-10 21:34:01 +0200
commitd65ecc589d2568a191f6245a00a305278107f6fd (patch)
treeb6fdcf4efc38822c010eddf9d9ecbb169b8cda3a /PKGBUILD
parent7089a40059ee3682e2034a6e1db96df97dc960e7 (diff)
downloadaur-d65ecc589d2568a191f6245a00a305278107f6fd.tar.gz
Make compatible with yay
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a80a4de5cc6..bd1c4aaabcac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,6 +13,7 @@ makedepends=("git" "go-pie" "npm")
source=("git+https://github.com/usefathom/fathom.git")
md5sums=("SKIP")
_gitname="fathom"
+blddir="build"
pkgver() {
cd "$_gitname"
@@ -22,17 +23,16 @@ pkgver() {
prepare(){
mkdir -p gopath/src/github.com/usefathom
ln -rTsf "$_gitname" gopath/src/github.com/usefathom/fathom
- export GOPATH="$srcdir"/gopath
}
build(){
- export GOPATH="$srcdir"/gopath
- cd "$srcdir"/"$_gitname"
+ cp -r "$srcdir" "$blddir"
+ export GOPATH="$blddir"/gopath
make build
}
package(){
- cd "$srcdir"/"$_gitname"
+ cd "$blddir"/"$_gitname"
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
install -Dm755 fathom "$pkgdir"/usr/bin/fathom
} \ No newline at end of file