summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhys Perry2019-09-07 17:56:11 +0100
committerRhys Perry2019-09-07 17:56:11 +0100
commitfe6c2569f0401d2c48da532162c9ca48060985d1 (patch)
tree791e5ebedd8fa4dfebfbdc55a0e7d9b3ab2d9c6a /PKGBUILD
parent70a8eaf572a6a8421945053c873e30392263b88f (diff)
downloadaur-fe6c2569f0401d2c48da532162c9ca48060985d1.tar.gz
Add proper versioning
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de6d9c506d7b..3a80a4de5cc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname="fathom-git"
pkgrel=1
-pkgver="i.dont.know.what.to.put.here"
+pkgver="v1.2.1.r43.gb278944"
pkgdesc="Fathom - simple website analytics (Community Edition)"
url="https://github.com/usefathom/fathom"
license=("MIT")
@@ -14,6 +14,11 @@ source=("git+https://github.com/usefathom/fathom.git")
md5sums=("SKIP")
_gitname="fathom"
+pkgver() {
+ cd "$_gitname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare(){
mkdir -p gopath/src/github.com/usefathom
ln -rTsf "$_gitname" gopath/src/github.com/usefathom/fathom