summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Whatson2020-07-30 19:31:40 +1000
committerAndrew Whatson2020-07-30 19:31:40 +1000
commit9a54e55dc109015fb3b973d4530056d7ca86f78d (patch)
tree67d26075760412ccdddb18be8d1be55d80eb1f3c /PKGBUILD
parent0e9cc336bc3bc1ada9351623f6c0c3494ca6a71c (diff)
downloadaur-faudio-git.tar.gz
Now using gstreamer, not ffmpeg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0821d72ea853..924863cddb78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
_pkgname=faudio
pkgname=${_pkgname}-git
-pkgver=19.08.r0.g2cc0ee5
-pkgrel=2
+pkgver=20.07.r11.g74b38f7
+pkgrel=3
pkgdesc="XAudio2 reimplementation"
arch=(x86_64)
url="https://github.com/FNA-XNA/FAudio/"
license=('custom:zlib')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-depends=('sdl2' 'ffmpeg')
+depends=('sdl2' 'gstreamer' 'gst-plugins-base-libs')
makedepends=('git' 'cmake')
source=('git+https://github.com/FNA-XNA/FAudio'
'faudio.pc')
@@ -32,7 +32,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DFFMPEG=ON
+ -DGSTREAMER=ON
make
}