summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlbert Graef2017-12-12 06:56:08 +0100
committerAlbert Graef2017-12-12 06:56:08 +0100
commit4626f43d8b691bbf730976db8a50eee4c5ed26db (patch)
tree94bf6028dc2f0980fa2be3b9471c70e101a8e16f /PKGBUILD
parente3fa57535be4d1c0ae524e81525263dc48d7970e (diff)
downloadaur-4626f43d8b691bbf730976db8a50eee4c5ed26db.tar.gz
Fix up PKGBUILD for latest upstream changes (libraries in submodule).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 027daedd7887..f941827b0c6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Albert Graef <aggraef at gmail.com>
pkgname=faustlive-git
-pkgver=787.46f15b9
+pkgver=799.0207de7
pkgrel=1
pkgdesc="A graphical frontend to the Faust compiler."
arch=('i686' 'x86_64')
@@ -15,16 +15,19 @@ depends=('qt4' 'faust2-git' 'jack2' 'qrencode' 'libmicrohttpd' 'openssl' 'liblo'
makedepends=('git')
provides=('faustlive')
conflicts=('faustlive')
-source=("$pkgname::git+https://github.com/grame-cncm/faustlive.git")
+source=("$pkgname::git+https://github.com/grame-cncm/faustlive.git#branch=dev")
md5sums=('SKIP')
pkgver() {
cd $srcdir/$pkgname
- # Make sure that we get the dev branch.
- git checkout dev > /dev/null 2>&1
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
+prepare() {
+ cd $srcdir/$pkgname
+ git submodule update --init
+}
+
build() {
cd $srcdir/$pkgname
make arch=Linux PREFIX=/usr STATIC=0 NETJACK=1