summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Cromer2020-08-16 14:36:30 -0400
committerChris Cromer2020-08-16 14:36:30 -0400
commit235ef7d0abb7eac3f62f418b70503b851af85ec1 (patch)
treeaa9afdb702bd3670556ab7ca69fba97f8b6d8051 /PKGBUILD
downloadaur-235ef7d0abb7eac3f62f418b70503b851af85ec1.tar.gz
initial 0.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..198def9e9f7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Chris Cromer <chris@cromer.cl>
+
+pkgname=faustus-rublag-dkms-git
+_pkgname=faustus
+pkgver=0.2
+pkgrel=1
+pkgdesc="Experimental unofficial Linux platform driver module for ASUS TUF Gaming series laptops with fan mode polling."
+arch=("x86_64")
+url="https://github.com/rublag/faustus"
+license=("GPL")
+depends=("dkms")
+makedepends=("git")
+conflicts=("faustus-dkms-git")
+source=("git+https://github.com/hackbnw/faustus.git")
+sha512sums=("SKIP")
+
+pkgver() {
+ source "${srcdir}/${_pkgname}/dkms.conf"
+ echo "${PACKAGE_VERSION}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/src/${_pkgname}-${pkgver}"
+ cp -r ${_pkgname}/* "${pkgdir}"/usr/src/${_pkgname}-${pkgver}/
+
+ install -D <(printf 'blacklist %s\n' "asus_wmi" "asus_nb_wmi") "${pkgdir}/etc/modprobe.d/${_pkgname}.conf"
+ install -D <(printf '%s\n' "${_pkgname}") "${pkgdir}/etc/modules-load.d/${_pkgname}.conf"
+}