summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos José Ruiz-Henestrosa Ruiz2020-07-21 17:01:37 +0200
committerCarlos José Ruiz-Henestrosa Ruiz2020-07-21 17:01:37 +0200
commit6a0c8b005b84e8c4ebb5cb53090c51e4345445d8 (patch)
tree9592165155f0ffc5ab33a40bf948969bd3a72c0c /PKGBUILD
parent1343f6092662f816bac043b46e61255835ed2d98 (diff)
downloadaur-6a0c8b005b84e8c4ebb5cb53090c51e4345445d8.tar.gz
Added pkgdesc and spreadsheet optdepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a23a04c8bde2..3852532ba88c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,32 @@
# Contributor: Ng Oon-Ee <ngoonee.talk@gmail.com>
pkgname=fava-git
_name=${pkgname%-git}
-pkgver=1.9.r29.g9e7c51af
+pkgver=1.15.r11.g2f140b23
pkgrel=1
-pkgdesc=""
+pkgdesc="Web interface for beancount"
arch=('any')
url="https://beancount.github.io/fava/"
license=('MIT')
groups=()
-depends=('beancount' # >=2.1.2, but beancount-hg doesn't provide a version.
- 'python'
+depends=('beancount>=2.3.0'
+ 'python>=3.6'
'python-setuptools'
+ 'python-babel>=2.6.0'
+ 'python-cheroot'
+ 'python-flask-babel>=1.0.0'
+ 'python-flask>=0.10.1'
+ 'python-jinja>=2.10'
+ 'python-click'
'python-markdown2>=2.3.0'
- 'python-flask-babel>=0.10.0'
- 'python-simplejson>=2.3.0'
- 'python-cheroot')
+ 'python-ply'
+ 'python-simplejson>=3.2.0'
+ 'python-werkzeug>=0.15.0')
+
+optdepends=('python-pyexcel>=0.2.2: Spreadsheet (ODS/XLS/XLSX) support'
+ 'python-pyexcel-ods3>=0.1.1: ODS file support'
+ 'python-pyexcel-xls>=0.1.0: XLS file support'
+ 'python-pyexcel-xlsx>=0.1.0: XLSX file support')
+
makedepends=('git'
'nodejs'