summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaichi Shinozaki2015-12-27 21:52:00 +0000
committerDaichi Shinozaki2015-12-27 21:52:00 +0000
commit8f6f0e0da263b4f4b9a69a373c770eb386f52e13 (patch)
tree8aeb47fc6e83cea1531a7caf09a2d5a110759136 /PKGBUILD
parent6de299a2735cc0bf6c8e17ee3b3a2dc1ff7e8a02 (diff)
downloadaur-8f6f0e0da263b4f4b9a69a373c770eb386f52e13.tar.gz
Bump version to 0.31.0 (with patches)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a847fe4fd20e..13910ae92b0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
pkgname=fbthrift
-pkgver=0.27.0
+pkgver=0.31.0
pkgrel=1
pkgdesc="Facebook's branch of Apache Thrift, including a new C++ server"
arch=('i686' 'x86_64')
url="https://github.com/facebook/fbthrift"
license=('Apache')
-depends=('folly<=0.48.0' 'krb5' 'numactl' 'python2')
+depends=('folly' 'krb5' 'numactl' 'python2')
conflicts=('thrift')
provides=('thrift')
makedepends=('scons')
@@ -16,14 +16,15 @@ source=("https://github.com/facebook/$pkgname/archive/v${pkgver}.tar.gz"
'CompactProtocol.h.patch'
'Serializer.h.patch'
'Krb5CredentialsCacheManager.cpp.patch'
-'t_rb_generator.cc.patch'
+#'t_rb_generator.cc.patch'
+'GeneratedCodeHelper.h.patch'
)
-md5sums=('dc555767b60dc165c3c8ee9c1697dcae'
+md5sums=('80d180ea65b03c7f68834159ab45a7ae'
'5a410a5ffdd4813f9844c06b37cdd048'
'067b4fc38a9e73cc06bd8d29eeb95c4f'
'ae028ff57127ee3f3c44b5b592b09199'
'bda963346b5171e59bacc0034868fa63'
- '54be1e53c1bd49d2855a3c52e13ed137')
+ '15166953d352fdf64c1009a5b7dbdc6c')
prepare() {
cd "$pkgname-$pkgver/thrift"
@@ -31,7 +32,11 @@ prepare() {
patch -p2 --verbose < $srcdir/CompactProtocol.h.patch
patch -p2 --verbose < $srcdir/Serializer.h.patch
patch -p2 --verbose < $srcdir/Krb5CredentialsCacheManager.cpp.patch
- patch -p2 --verbose < $srcdir/t_rb_generator.cc.patch
+# patch -p2 --verbose < $srcdir/t_rb_generator.cc.patch
+ cd lib/cpp2
+ patch -p0 --verbose < $srcdir/GeneratedCodeHelper.h.patch
+ cd ../../
+
sed -ie '1 s/python/python2/' ./compiler/py/main.py
# ArchLinux system has both libboost_python.so and libboost3_python.so.
# Use python2 for build, so prevent libboost3_python.so to be chosen