summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNaoya Inada2016-03-06 11:31:30 +0900
committerNaoya Inada2016-03-06 11:31:30 +0900
commit7e86f874ce43972bde409e1d9c6be6bc2bc251b4 (patch)
tree70406bc1031e2a2b97f48ce40046779591b13cb1 /PKGBUILD
parent425cfed8d326534ea593f68a7dd4d90d7ca66146 (diff)
downloadaur-7e86f874ce43972bde409e1d9c6be6bc2bc251b4.tar.gz
Update to mozc-2.17.2313.102 and mozc-ut-20160303
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 17 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4227597412de..c73e7dcec659 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,13 +53,13 @@
_bldtype=Release
_zipcode_rel=201511
-_mozcver=2.17.2106.102
-_utdicver=20151130
+_mozcver=2.17.2313.102
+_utdicver=20160303
_protobuf_rev=172019c40bf548908ab09bfd276074c929d48415
-_gyp_rev=cdf037c1edc0ba3b5d25f8e3973661efe00980cc
+_gyp_rev=e2e928bacd07fead99a18cb08d64cb24e131d3e5
_jsoncpp_rev=11086dd6a7eba04289944367ca82cea71299ed70
-_japanese_usage_dictionary_rev=10
-_mozc_rev=3648b9bf06d5d9b36bed2425640bfd18ae05b588
+_japanese_usage_dictionary_rev=e5b3425575734c323e1d947009dd74709437b684
+_mozc_rev=3306d3314499a54a4064b8b80bbc1bce3f6cfac4
_fonttools_rev=5ba7d98a4153fad57258fca23b0bcb238717aec3
_jsr305_ver=2.0.2
@@ -67,8 +67,8 @@ _pkgbase=mozc
pkgname=fcitx-mozc-ut
pkgdesc="Fcitx Module of A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input) with Mozc UT Dictionary (additional dictionary)"
pkgver=${_mozcver}.${_utdicver}
-_fcitx_patchver=2.17.2102.102.1
-pkgrel=3
+_fcitx_patchver=2.17.2313.102.1
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.geocities.jp/ep3797/mozc_01.html"
license=('custom')
@@ -77,15 +77,14 @@ makedepends=('pkg-config' 'python2' 'curl' 'gtk2' 'mesa' 'subversion' 'ninja' 'r
replaces=('mozc-fcitx' 'fcitx-mozc')
conflicts=('mozc' 'mozc-server' 'mozc-utils-gui' 'mozc-fcitx' 'mozc-ut' 'fcitx-mozc')
source=(mozc-${_mozcver}::git+https://github.com/google/mozc.git#commit=${_mozc_rev}
- jsoncpp::git+https://github.com/open-source-parsers/jsoncpp.git#commit=${_jsoncpp_rev}
- japanese_usage_dictionary::svn+http://japanese-usage-dictionary.googlecode.com/svn/trunk#revision=$_japanese_usage_dictionary_rev
- gyp::git+https://chromium.googlesource.com/external/gyp#commit=${_gyp_rev}
- protobuf::git+https://github.com/google/protobuf.git#commit=${_protobuf_rev}
+ japanese_usage_dictionary::git+https://github.com/hiroyuki-komatsu/japanese-usage-dictionary.git#commit=${_japanese_usage_dictionary_rev}
+ git+https://chromium.googlesource.com/external/gyp#commit=${_gyp_rev}
+ git+https://github.com/google/protobuf.git#commit=${_protobuf_rev}
fontTools::git+https://github.com/googlei18n/fonttools.git#commit=${_fonttools_rev}
"x-ken-all-${_zipcode_rel}.zip::http://download-codeplex.sec.s-msft.com/Download/Release?ProjectName=naoina&DownloadId=1527310&FileTime=130941443058430000&Build=21031"
"edict-${_utdicver}.gz::http://download-codeplex.sec.s-msft.com/Download/Release?ProjectName=naoina&DownloadId=1527309&FileTime=130945321365000000&Build=21031"
"jigyosyo-${_zipcode_rel}.zip::http://download-codeplex.sec.s-msft.com/Download/Release?ProjectName=naoina&DownloadId=1527311&FileTime=130941443059370000&Build=21031"
- mozcdic-ut-${_utdicver}.tar.bz2::http://osdn.jp/frs/chamber_redir.php?f=%2Fusers%2F9%2F9619%2Fmozcdic-ut-${_utdicver}.tar.bz2
+ mozcdic-ut-${_utdicver}.tar.bz2::https://osdn.jp/frs/chamber_redir.php?f=%2Fusers%2F9%2F9993%2Fmozcdic-ut-${_utdicver}.tar.bz2
EDICT_license.html
mod-generate-mozc-ut.sh
http://findbugs.googlecode.com/svn/repos/release-repository/com/google/code/findbugs/jsr305/$_jsr305_ver/jsr305-$_jsr305_ver.jar
@@ -122,7 +121,7 @@ prepare() {
# Copy third party deps
cd "$srcdir"
- for dep in jsoncpp gyp protobuf japanese_usage_dictionary fontTools
+ for dep in gyp protobuf japanese_usage_dictionary fontTools
do
cp -a $dep mozc-ut-${pkgver}/third_party/
done
@@ -140,8 +139,8 @@ build() {
_targets="server/server.gyp:mozc_server gui/gui.gyp:mozc_tool unix/fcitx/fcitx.gyp:fcitx-mozc"
- QTDIR=/usr GYP_DEFINES="document_dir=/usr/share/licenses/$pkgname" python2 build_mozc.py gyp
- python2 build_mozc.py build -c $_bldtype -j 8 $_targets
+ QTDIR=/usr GYP_DEFINES="document_dir=/usr/share/licenses/$pkgname use_libzinnia=1" python2 build_mozc.py gyp
+ python2 build_mozc.py build -c $_bldtype $_targets
# Extract license part of mozc
head -n 29 server/mozc_server.cc > LICENSE
@@ -191,13 +190,12 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'bacb68bc64dd62322d332f38babf3c9933bf4a113081d795c8bc7e33a8e8e4e3e47320fd520f522c55830f519337c828c115ddb3275ace3076ebff4480b20805'
'35c8c0b283e53f9c249b1a66e668acfe439223cabe4e0ba83fdc5fcc250c53ce2cf9df20f0e74cc66ee670f6684286f316f7dd855620aa14248a74e516366293'
'9ebc0565366533ade36c5af19e47165641bb4d75393f87ba971e27d5bed038795731cb7426d769740ebf6cc3b91ca7c1f5cab200ac82097a3f880414a220d166'
- 'dde61d78c2ecd65f6029dfe72e4f9cc26318c8e5f41eaf7dbe981fbd2b066fbc09bf4763c77d11effa54e45a378f50273a53ce494969ef78659b9a93a9d8b430'
+ '405039d3fc6ef1625c5803a1ee6a34efeb9cb240bd4f326ec2f25ebb99f5ebddc52efeea6ff83cfea2db293eb9dcc395190102ec02cd893616aa85fb5172a3dc'
'4899c7ee01e387c7c5c628356a0b32e7ba28643580701b779138361ca657864ec17ae0f38d298d60e44093e52a3dfe37d922f780b791e3bd17fc4f056f22dbbb'
- '4668967b324261b4643cf4876a65f82a7157df140ca9fa0aa89d5cd39c87961eeabfbe63b20a2acc393acdff6c6284477d47f5a1d4967db64e0521c65ef9c0e4'
+ '5e014b3238539d4f7887a1086e15baf27f5c32363d5881dffdf5882a24ff1e28b4f2b36614f7c0b7534d92a5313bc900e89de1256f3ed4169960aa32b7bf73dd'
'b3b832489ef9249b22d8a0b9d6eee1895c9d93ef53d5968724a65184cb3f04e17cc74938128b98916da7829c6566be0bc6d60fa8801248cc24620730a060eac6'
- '096673f036d236d262c05d7b0625504024899d8208c7c4ecd1250dff05dcedb2f066e8c96e05241f66c846931dab6ac466927f1a0339467c7ef4808883a36ee1'
+ 'a9a3ca5dba636c84d216a0a3574e5132d0e6ca69e913ccd5f1a1716af238ea34d5100a4b5d42bbd0c12649780b6009f4533e848e86050e51c22dc8859badd615'
'5507c637e5a65c44ccf6e32118b6d16647ece865171b9a77dd3c78e6790fbd97e6b219e68d2e27750e22074eb536bccf8d553c295d939066b72994b86b2f251a')