summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNanaka Hiira2024-06-19 05:57:00 +0900
committerNanaka Hiira2024-06-19 05:57:00 +0900
commite340fe3fa750cb7667d1b9dabcae08e9bac2e0f5 (patch)
tree40bbcbd8f3c1ee9f9c70ade3c9da978afe94181d /PKGBUILD
downloadaur-e340fe3fa750cb7667d1b9dabcae08e9bac2e0f5.tar.gz
0.0.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4bd40920bbdd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Nanaka Hiira <hiira plus archlinux at hiira dot dev>
+pkgname=fcitx5-hazkey-bin
+pkgver=0.0.3
+pkgrel=1
+pkgdesc="Japanese input method for fcitx5, powered by azooKey engine"
+arch=('x86_64')
+url="https://github.com/7ka-Hiira/fcitx5-hazkey"
+license=('MIT')
+depends=('fcitx5>=5.0.4')
+conflicts=('fcitx5-hazkey' 'fcitx5-hazkey-git')
+provides=('fcitx5-hazkey')
+source=("https://github.com/7ka-Hiira/fcitx5-hazkey/releases/download/0.0.3/fcitx5-hazkey-0.0.3-x86_64.tar.gz"
+ "LICENSE")
+sha256sums=('a27423e1bf66ca4b892bce12fda4a56bbb742dfd0ca1bea5bcbdb05a94b140ff'
+ '36ae30a03484d88f0f90e1985750b0a3f43521bf0a5c8112354bec2de60e0c5b')
+options=(!strip)
+
+prepare() {
+ mkdir -p "$srcdir/fcitx5-hazkey"
+ tar -xf "$srcdir/fcitx5-hazkey-$pkgver-x86_64.tar.gz" -C "$srcdir/fcitx5-hazkey"
+}
+
+package() {
+ cp -a "$srcdir/fcitx5-hazkey/usr" "$pkgdir/"
+
+ # Move files to adapt to Arch Linux environment
+ cd "$pkgdir"
+ cp -a usr/lib/x86_64-linux-gnu/* usr/lib/
+ rm -rf usr/lib/x86_64-linux-gnu/
+
+ chmod +x usr/lib/fcitx5/fcitx5-hazkey.so
+ chmod +x usr/lib/libhazkey.so
+
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+} \ No newline at end of file