summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorm8D22024-04-01 16:41:48 -0700
committerm8D22024-04-01 16:41:48 -0700
commit490817576a8fe9b96916763a5d45b94b6e401127 (patch)
tree861265c8cb49a3d3a80663488e3e1237b03ae506 /PKGBUILD
parentcf564b6e97e8db3dab44f058df67cd2647d70c44 (diff)
downloadaur-fcitx5-skin-adwaita-dark.tar.gz
upstream update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 770d3d9c0f48..51fd79cb6087 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,35 @@
# Maintainer: Coelacanthus <liuhongwu2003@outlook.com>
pkgname=fcitx5-skin-adwaita-dark
-_pkgname=fcitx5-adwaita-dark
-pkgver=0.0.0.20200806
-_commit=2938a7cf417ec149aa26fc35949911ae297b0799
+pkgver=r9.1d45848
pkgrel=1
pkgdesc="An Fcitx5 dark theme mimics GNOME Adwaita-dark"
-arch=('any')
+arch=(any)
+makedepends=(git)
url="https://github.com/escape0707/fcitx5-adwaita-dark"
license=('AGPL3')
-source=("https://github.com/escape0707/fcitx5-adwaita-dark/archive/$_commit/$_pkgname-$_commit.tar.gz")
-sha512sums=('452463eab11e481ad81ef100c43284dd00d2bff1d75978afdcfba42ca75e54d34ae02d0da9aa8018d981c76241431b860c35d07cb3ceeb25170a5cc6939b7faf')
+makedepends=(git)
+source=("$pkgname::git+$url#commit=1d45848312368595f3eeb9c246f203ca7032cbdd")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+
+ # no tags then use number of revisions since beginning of the history
+ # https://wiki.archlinux.org/title/VCS_package_guidelines#The_pkgver()_function
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
package() {
- _variant_name=adwaita-dark
- cd $_pkgname-$_commit
- install -Dm644 highlight.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/highlight.png
- install -Dm644 no_highlight.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/no_highlight.png
- install -Dm644 panel.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/panel.png
- install -Dm644 arrow.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/arrow.png
- install -Dm644 radio.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/radio.png
- install -Dm644 theme.conf "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/theme.conf
+
+ cd $srcdir/$pkgname
+ install -Dm644 highlight.png "$pkgdir"/usr/share/fcitx5/themes/adwaita-dark/highlight.png
+ install -Dm644 no_highlight.png "$pkgdir"/usr/share/fcitx5/themes/adwaita-dark/no_highlight.png
+ install -Dm644 panel.png "$pkgdir"/usr/share/fcitx5/themes/adwaita-dark/panel.png
+ install -Dm644 arrow.png "$pkgdir"/usr/share/fcitx5/themes/adwaita-dark/arrow.png
+ install -Dm644 radio.png "$pkgdir"/usr/share/fcitx5/themes/adwaita-dark/radio.png
+ install -Dm644 theme.conf "$pkgdir"/usr/share/fcitx5/themes/adwaita-dark/theme.conf
#install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}