summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCebtenzzre2018-08-10 16:16:51 -0400
committerCebtenzzre2018-08-10 16:16:51 -0400
commit3c4aa6a8b0a7387c7d0736e7a2aa0b1ff9b3fa05 (patch)
treef0d4f00eb0f98b1b4cdf398f1cffc53c053359f7 /PKGBUILD
downloadaur-3c4aa6a8b0a7387c7d0736e7a2aa0b1ff9b3fa05.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87c4e5261e04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Cebtenzzre <cebtenzzre (at) gmail (dot) com>
+
+_pkgname=fcode-utils
+pkgname="${_pkgname}-git"
+pkgver=v1.0.2.r20.gd89219a
+pkgrel=1
+pkgdesc="A set of utilities to process FCODE, OpenFirmware's byte code"
+arch=(x86_64 i686)
+url='https://www.openfirmware.info/FCODE_suite'
+license=(GPL2 CPL)
+depends=('glibc')
+makedepends=('git')
+source=("git+https://github.com/openbios/${_pkgname}.git"
+ 'nicer_flags.patch')
+sha256sums=('SKIP'
+ 'eba18cb2f7ecc20a4018a9e79f79d0845b42adba3320240933bd881f3901034e')
+provides=('romheaders')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname"
+
+ # Fix the not-so-nice flag replacement and ignoring
+ patch -p1 -i ../nicer_flags.patch
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make install DESTDIR="$pkgdir/usr"
+}