summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaurycy Z2022-03-24 16:12:58 -0700
committerMaurycy Z2022-03-24 16:12:58 -0700
commit4ec09e1e534582184e17bd901a4b9416ba816d6c (patch)
tree8094487667938885e55b71400d6d8f84af49c1f3 /PKGBUILD
parent895b4b88c2ae3dc6db904c358824348168fdde66 (diff)
downloadaur-fcron-dev.tar.gz
add smpt-forwarders as an optional dep, add yes to makepkg, provide cron
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea6f920eec8e..6a0e0ac7246f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: Maurycy <10maurycy10@gmail.com>
pkgname=fcron-dev
pkgver=3.3.1
-pkgrel=1
+pkgrel=2
pkgdesc='fcron - daemon to execute scheduled task.'
arch=('any')
url='http://fcron.free.fr/'
license=('GPL')
depends=('make' 'gcc')
+optdepends=('smtp-forwarder: notify results')
conflicts=("fcron")
+provides=('cron')
source=("http://fcron.free.fr/archives/fcron-${pkgver}.src.tar.gz")
sha256sums=("f359daa08a63ddfb7fe2f964bb3f5c52244c25aa36f9225a3cc54d36f4681106")
@@ -16,6 +18,6 @@ package() {
./configure --prefix="/usr" --sysconfdir="/etc" --with-systemdsystemunitdir="/etc/systemd/system" --sbindir="/usr/bin" --with-pam=no
sed -i 's/systemctl daemon-reload//' Makefile
make -j$(nproc)
- make DESTDIR="${pkgdir}" install
+ yes | make DESTDIR="${pkgdir}" install
}