summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-02-28 18:49:36 +0800
committerzxp198210052024-02-28 18:49:36 +0800
commit4e980e37312cfc1652bc1fc39a7defb8e09fb81c (patch)
treef7989a761288b457e83ab1ecf2eb54b4b2f119b5 /PKGBUILD
parentb797bcf6b85542a06701c86fc9aa77410c5043e5 (diff)
downloadaur-4e980e37312cfc1652bc1fc39a7defb8e09fb81c.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d55f893fd44b..702104d80054 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,27 @@ pkgname=fdc3-sail-bin
_pkgname=FDC3-Sail
pkgver=22.12.6_1030
_electronversion=24
-pkgrel=6
+pkgrel=7
pkgdesc="Open implementation of the FDC3 standard using Electron and an integrated App Directory."
arch=('x86_64')
url="https://github.com/finos/FDC3-Sail"
-license=('Apache')
+license=('Apache-2.0')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
"electron${_electronversion}"
'hicolor-icon-theme'
- 'dbus-glib'
- 'libdbusmenu-glib'
- 'gtk2'
-)
-makedepends=(
- 'squashfuse'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver//_/-}/${_pkgname}-${pkgver//_/-}.AppImage"
"${pkgname%-bin}.sh"
)
sha256sums=('81243023ba6af8562e5244f6d48f2e4dd8f17ab77984dda7a55ad0863959ea97'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null