summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2023-05-04 01:16:11 +0300
committerCaleb Maclennan2023-05-04 01:16:11 +0300
commit736f50349c3cf2102701b673643494f537e941da (patch)
tree0d99fe1ed23aff8da8c095fcad09b5c9ef705818 /PKGBUILD
parentd6966705fadc418853cd28831a748a02e296c57d (diff)
downloadaur-736f50349c3cf2102701b673643494f537e941da.tar.gz
upgpkg: fdiff 3.0.0-3
Rebuild for Python 3.11, normalize PEP517 build tooling
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c17522fb596..53feb93441bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=fdiff
pkgver=3.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='An OpenType table diff tool for fonts based on the fontTools TTX format'
arch=(any)
url="https://github.com/source-foundry/$pkgname"
@@ -14,17 +14,18 @@ _py_deps=(aiodns
rich)
depends=(python
"${_py_deps[@]/#/python-}")
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_archive="$pkgname-$pkgver"
source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('4d00db17bb5d9980d92a395ceac43559c11c35347c43a12e599123745fe67f7d')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}