summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Landau2016-01-06 11:26:11 +0200
committerDaniel Landau2016-01-06 11:26:11 +0200
commit39068c2bf088ea847353ed766bc7b3286df3a8ce (patch)
tree1fc16e62140145b3f8f6e12b686cdc1c263895bd /PKGBUILD
parent8ede87ff50b60f698b5fdf86fdb22cc0348eaaa8 (diff)
downloadaur-39068c2bf088ea847353ed766bc7b3286df3a8ce.tar.gz
update version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b47bf853f10..c4d0111623a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
# Ported from the package by AlexanderR <alexander r at gmx com>
pkgname=fdroidserver
-pkgver=0.4.0
-_hash=bad611ce5a3b4d1c2cd72a300da56979e1605d90
+pkgver=0.5.0
epoch=2
pkgrel=1
pkgdesc="F-Droid repository management tools"
url="https://gitlab.com/fdroid/$pkgname"
license=('GPL3')
-depends=('python2' 'python2-pyasn1' 'python2-pyasn1-modules' 'python2-magic' 'python2-requests')
+depends=('python2' 'python2-pyasn1' 'python2-pyasn1-modules' 'python2-magic' 'python2-requests' 'python2-yaml')
makedepends=('python2-setuptools' 'python2-pillow' 'python2-paramiko' 'java-environment')
optdepends=(
'android-sdk: Build apps from source'
@@ -35,10 +34,10 @@ optdepends=(
arch=('any')
options=(!emptydirs)
source=("https://gitlab.com/fdroid/${pkgname}/repository/archive.tar.gz?ref=${pkgver}")
-sha256sums=('64d6ec15f2947104a08840f10f53b2e5150cc84cdb5caf742fdf6e264a9c82b1')
+sha256sums=('3a4a2cab9b22d135dae6b4c9d0a2a8ac1c5af0b544d9f8bb145f3b09d3f10921')
package() {
- cd "$srcdir/${pkgname}-${pkgver}-${_hash}"
+ cd "${srcdir}/${pkgname}-${pkgver}-"*
python2 setup.py install --root="$pkgdir/" --optimize=1 --install-data="/tmp" || true
rm -rf "$pkgdir/tmp"