summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Mattern2022-05-06 20:28:37 +0200
committerPeter Mattern2022-05-06 20:28:37 +0200
commitb42659879789aa63d3d53cfd4a6007b118ce774b (patch)
tree61b23e827f72133eea2f889162eb1dad7c29fd7e /PKGBUILD
parente79bca49ffb7872a2c155ce1d9ae7eec0db1040e (diff)
downloadaur-feathernotes-git.tar.gz
Build against Qt 6
Relevant upstream commits: introduction in 9cb610a7, fix in f7a94180.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be8ddad139ed..68aad3c03814 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
_pkgname=feathernotes
pkgname=$_pkgname-git
-pkgver=0.10.0.10.gf0a367c
+pkgver=0.10.0.14.g9cb610a
pkgrel=1
pkgdesc='Lightweight Qt hierarchical notes-manager for Linux.'
arch=('i686' 'x86_64')
url='https://github.com/tsujan/feathernotes'
license=('GPL3')
-depends=('qt5-x11extras' 'qt5-svg' 'shared-mime-info' 'desktop-file-utils' 'hunspell')
-makedepends=('git' 'cmake' 'qt5-tools')
-optdepends=('qt5-translations: localized keyboard shortcuts')
+depends=('qt6-svg' 'shared-mime-info' 'desktop-file-utils' 'hunspell')
+makedepends=('git' 'cmake' 'qt6-tools')
+optdepends=('qt6-translations: localized keyboard shortcuts')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$_pkgname::git+${url}.git")
@@ -24,7 +24,7 @@ pkgver() {
build() {
rm -Rf build && mkdir build
cd build
- cmake $srcdir/$_pkgname/
+ cmake $srcdir/$_pkgname/ -DENABLE_QT5=OFF
make
}