summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Mattern2016-10-05 17:59:19 +0200
committerPeter Mattern2016-10-05 17:59:19 +0200
commitf1103e88467339f46da3d38bb2b6e1e0d96ceac7 (patch)
tree9cfd39b1e00d070ad08339c9c5bc10893779ba70 /PKGBUILD
downloadaur-f1103e88467339f46da3d38bb2b6e1e0d96ceac7.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4d778a865f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Peter Mattern <pmattern at arcor dot de>
+
+pkgname=featherpad
+pkgver=0.5.7
+pkgrel=1
+pkgdesc='Lightweight Qt5 plain text editor for Linux'
+arch=('i686' 'x86_64')
+url='https://github.com/tsujan/FeatherPad'
+license=('GPL3')
+depends=('qt5-svg' 'qt5-x11extras' 'desktop-file-utils' 'gtk-update-icon-cache')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/tsujan/FeatherPad/archive/V$pkgver.tar.gz")
+sha256sums=('41df1f098646027679421c7d574f20f034613f164b616d997913895aa032e035')
+
+build() {
+ rm -Rf build && mkdir build
+ cd build
+ qmake $srcdir/FeatherPad-$pkgver/
+ make
+}
+
+package() {
+ cd build
+ make INSTALL_ROOT=$pkgdir install
+}